Re: SWR Workingman 10


[ Follow Ups ] [ Post Followup ] [ Electricbass.com WWWBoard ] [ FAQ ]

Posted by Mickster on October 19, 2001 at 12:28:45:

In Reply to: SWR Workingman 10 posted by anonymouse on October 18, 2001 at 22:35:02:

: I just bought a SWR Workingman 10 and there is an annnoying 60 cycle hum. Anybody else have this problem.

: I don't have the hum in my Bassic Black 15".

: Wanted to know if I should take it back to the store ans do a switch.

Anonymouse, I would definitely take it back. I've had a Fender Bassman 60 amp for about 15 months, and loved it. All of a sudden about two weeks ago it got an annoying hum that came out of nowhere. I asked a few people I know for advice, but, anything they suggested did not work. Now, the midrange control doesn't work, and the speaker sometimes makes a weird flapping sound. I checked it, it's not blown, but, I must assume the amp is. If your amp is brand new, I'd say take it back and have them fix it, or replace it. Amps should not hum. Because of this, I just bought an Ampeg B100 R combo; 100watts through 1-15 and it's supposed to have real vintage tone. A few people recommended it, and I checked out reviews posted on it at www.harmonycentral.com. I am so ticked off though about the Fender. I guess I just got a lemon.

Get your's checked if it's still has a warranty.
Mickster




Follow Ups:



Post a Followup

Name:
E-Mail:

Subject:

Comments:

Optional Link URL:
Link Title:
Optional Image URL:


[ Follow Ups ] [ Post Followup ] [ Electricbass.com WWWBoard ] [ FAQ ]