Re: Carvin LB75F - Bought a used one and happy with it but....


[ Follow Ups ] [ Post Followup ] [ Electricbass.com WWWBoard ] [ FAQ ]

Posted by splatbass on January 09, 2001 at 11:28:30:

In Reply to: Carvin LB75F - Bought a used one and happy with it but.... posted by DDazey on January 09, 2001 at 10:05:59:

: I have a question or two about the LB75F. When I first recieved it I really loved the feel and tone but I've been having problems with the input. It seems that the input is not connecting well when I plug the cord in. I ordered an input from Carvin but it turned out to be the wrong type. The input on my bass has several more wires connected in a unique way from what I've seen on my other basses. Does it sound like I'm on the right track and that I need to order a new input jack or is there something else that can be done to make the connection better.

: The other issue I have been having with it is the tone controls. I have 5 knobs on my LB75F, the Volume and Pan knob on top and the three tone knobs on bottom. The Problem I'm having is that I have a hard time distinguishing between the treble/mid/bass knobs. When I first got the bass I didn't notice it or thought it worked fine, but lately they just don't sound right. I can hear a slight change in tone when adjusting the three tone knobs but you would have a hard time figuring out which is the treble and which is the bass knob. I've changed the battery with no improvement. I'm wondering if my input jack problem could be related. Any thoughts?

: Maybe I should just take it to someone to work on that knows more than I do. Are there carvin specialist to be found or will I have to ship this to Carvin?

: Any thoughts would be appreciated.

: Thanks,
: DDazey

The "input" you are talking about is actually the output jack. Maybe that's why Carvin sent you the wrong part. As far as the EQ, the power on switch is in the output jack, so if that were the problem, it most likely wouldn't work at all (no sound). Do Carvin basses still have a passive mode, where the EQ (tone) knobs are bypassed? They used to have that option, with a switch to switch between active and passive. Maybe it is stuck in bypass, where the EQ wouldn't work.



Follow Ups:



Post a Followup

Name:
E-Mail:

Subject:

Comments:

Optional Link URL:
Link Title:
Optional Image URL:


[ Follow Ups ] [ Post Followup ] [ Electricbass.com WWWBoard ] [ FAQ ]